Riddled TV Repair Forum
Service Menu and Manual Schematics
 
   
 FAQFAQ   SearchSearch   RegisterRegister 
   Log inLog in 
Magnavox 42MF231D/17 42" plasma No picture, no sound    
Post new topic   Reply to topic    Riddled TV Repair Forum Index -> TV Repair
 
Author Message
jrt896



Joined: 11 Dec 2009
Posts: 5
Location: USA

PostPosted: Fri Dec 11, 2009 12:52 pm    Post subject: Magnavox 42MF231D/17 42" plasma No picture, no sound Reply with quote

Model 42MF231D/17
No picture, no sound and blue power button light. Replaced one bulging cap, no change. I saw the post about a 37" maggie and was curious if there is a pic of the suspect parts I could reference. Thanks all.
Google

PostPost subject: Advertisement

Jesse Mack



Joined: 22 May 2008
Posts: 600
Location: The Last Frontier

PostPosted: Fri Dec 11, 2009 1:51 pm    Post subject: Reply with quote

The previous post was about a LCD television. If the model number (/D17) you gave is correct you have a plasma tv. A LCD tv is /D37 in the model number.

If you indeed have a /D17 check the VS and VA voltage on the power supply for coming up even for a little while when powering up.

Jesse
jrt896



Joined: 11 Dec 2009
Posts: 5
Location: USA

PostPosted: Fri Dec 11, 2009 2:10 pm    Post subject: Reply with quote

yes, it is a plasma. I will check the voltages after work tonight. Do you have an idea of what they should read?
Jesse Mack



Joined: 22 May 2008
Posts: 600
Location: The Last Frontier

PostPosted: Fri Dec 11, 2009 2:14 pm    Post subject: Reply with quote

The values will be on a sticker on the panel itself as to what the levels of the VS and VA voltages should be.

Jesse
jrt896



Joined: 11 Dec 2009
Posts: 5
Location: USA

PostPosted: Fri Dec 11, 2009 2:15 pm    Post subject: Reply with quote

ok,
I had my roommate test them.
VS comes up at 204vdc
VA reads 70.3vdc

These are within the range posted on the board
vs 195 -215
VA - 50-70
Google

PostPost subject: Advertisement

jrt896



Joined: 11 Dec 2009
Posts: 5
Location: USA

PostPosted: Fri Dec 11, 2009 2:56 pm    Post subject: Reply with quote

I should note that the cap I replaced was C5040 on what I believe is the Y main board. I still have a faint smell coming from that area as well
jrt896



Joined: 11 Dec 2009
Posts: 5
Location: USA

PostPosted: Sat Dec 12, 2009 12:38 pm    Post subject: Reply with quote

Upon further investigation, I have found a burnt out component on the Y upper board (U5405). Coincidently, this is the smell I mentioned earlier. So, now I was wondering if there is a way to test the Y main without having the new Y upper. I just want to be sure I don't ruin my new board. Any tips would be greatly appreciated
tv2011



Joined: 20 May 2011
Posts: 1
Location: usa

PostPosted: Fri May 20, 2011 5:00 pm    Post subject: plasma tv no picture no sound blue light on Reply with quote

Hi jrt896 i was wondering if you ever found out what was wrong with your tv? i know it was a long time ago i have the same problem with mine i get a faint smell and sound like a zapping electric current
please let me know if you fixed yours

THANKS!
Display posts from previous:   
Post new topic   Reply to topic    Riddled TV Repair Forum Index -> TV Repair All times are GMT - 6 Hours
Page 1 of 1

 


Disclaimer: All information provided by RiddledTV is strictly for information purposes only. Please observe all warnings displayed on your electronic
devices. This information should only be used to help diagnose work, and all service should be performed by a qualified technician.
Contact Us       Privacy Policy       Copyright © 2015 RiddledTV.com       Advertise on RiddedTV.com