Riddled TV Repair Forum
Service Menu and Manual Schematics
 
   
 FAQFAQ   SearchSearch   RegisterRegister 
   Log inLog in 
VIZIO E420i-AO - No backlight    
Post new topic   Reply to topic    Riddled TV Repair Forum Index -> TV Repair
 
Author Message
42395_skyline



Joined: 30 Jul 2016
Posts: 1

PostPosted: Sat Jul 30, 2016 6:48 pm    Post subject: VIZIO E420i-AO - No backlight Reply with quote

I have a VIZIO E420i-AO that has no backlight. I can verify the display works via the flashlight test.

I have replaced the power and main board via eBay replacements and have the same issue. I tested the voltages on the new board going to the LED's by testing LED1, Vout1, LED2, Vout2. When the LED connector is unplugged and the TV is on I get abut .860V on LED1 and .890V on LED2 and 92-97V on Vout1 and 137-146V on Vout2. When the connector is plugged in and the TV is on I get 31-34V on LED1 and 55-62V on LED2 and 92-98V on Vout1 and 137-146V on Vout2.

Not sure if these reading are normal or not, but assuming they are how do I test the LED strips from the connector to see if the LED strips need to be replaced? I have a soldering iron and experienced in electronic repairs, just not TV's.
Google

PostPost subject: Advertisement

JTS1957



Joined: 21 Jan 2009
Posts: 2224
Location: Far, Far Away

PostPosted: Sat Jul 30, 2016 10:30 pm    Post subject: Reply with quote

Scroll down to the two YouTube videos.

HERE
Display posts from previous:   
Post new topic   Reply to topic    Riddled TV Repair Forum Index -> TV Repair All times are GMT - 6 Hours
Page 1 of 1

 


Disclaimer: All information provided by RiddledTV is strictly for information purposes only. Please observe all warnings displayed on your electronic
devices. This information should only be used to help diagnose work, and all service should be performed by a qualified technician.
Contact Us       Privacy Policy       Copyright © 2015 RiddledTV.com       Advertise on RiddedTV.com